MON Staking is currently disabled

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Dec 26, 2025 - 03:21 EST

Investigating

We are currently investigating an issue impacting MON Staking. All customer accounts and funds remain secure. Further updates to follow.
Posted Dec 23, 2025 - 09:44 EST
This incident affected: Crypto Deposits and Withdrawals.