Service Disruption - Gemini Mobile App Registration
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 18:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 23, 2022 - 17:04 EDT
Investigating
Gemini is investigating an issue with new users being unable to register via the Mobile App.

All customer accounts and funds remain completely secure. Further updates to follow.
Posted Jun 23, 2022 - 16:13 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.