LTC Transfers Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 21:56 EDT

Investigating

Litecoin deposits and withdrawals are currently delayed. The team is investigating and working to restore normal processing. All customer accounts and funds remain completely secure.
Posted Oct 17, 2025 - 12:31 EDT
This incident affected: Digital Currencies (Litecoin Deposits and Withdrawals).