SGD (FAST) Withdrawal Failures
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 20:22 EST
Investigating
The team are investigating an issue which has caused some SGD (FAST) withdrawals to fail. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Feb 01, 2024 - 16:15 EST
This incident affected: Fiat Deposits and Withdrawals.