Filecoin Network Upgrade - Deposits and Withdrawals disabled
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 22:36 EDT
Investigating
Filecoin is currently going through a network upgrade and so all deposits and withdrawals for Filecoin are disabled until this upgrade is completed. We will be sure to update this page once the upgrade has finished.
Posted Apr 24, 2024 - 17:03 EDT
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).