Solana Deposits Delayed - 11/26/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 20:41 EST
Investigating
We are currently investigating an issue delayed Solana deposits. All customer accounts and funds remain secure. Further updates to follow.
Posted Nov 26, 2024 - 19:29 EST
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).