Email Delivery Partial Outage

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 20, 2025 - 11:00 EDT

Identified

Gemini has identified an incident impacting automated emails such as password resets and order confirmations.
Posted May 16, 2025 - 22:15 EDT