USD ACH and FedWire Delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 08:59 EST
Monitoring
FedWire processing has resumed for incoming and outgoing wires. ACH services are in process of resuming. We are continuing to monitor the situation.
Posted Feb 24, 2021 - 15:04 EST
Identified
USD ACH transfers and FedWire are currently delayed due to an outage at the Federal Reserve. All funds remain secure while we investigate the issue.
Posted Feb 24, 2021 - 13:02 EST
This incident affected: Wire Transfer Deposit and Withdrawals.