Gemini Credit Card call center

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 15:43 EDT

Investigating

Our Gemini Credit Card call center is experiencing higher than usual call volume. Customers are advised to email support@gemini.com
Posted Oct 21, 2025 - 09:21 EDT