Ethereum Withdrawals Temporarily Delayed -3/29/25

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 8 days ago. Mar 30, 2025 - 11:03 EDT

Investigating

We are currently investigating delays regarding Ethereum withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted 9 days ago. Mar 29, 2025 - 23:15 EDT
This incident affected: Digital Currencies (Ethereum Deposits and Withdrawals).