Degraded Performance - New User Agreements blocking access on App for Android users

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 01:00 EDT

Investigating

We are currently investigating this issue. All customer accounts and funds remain completely secure. Updates will be provided once they are available. Please try to accept the new User Agreements using the Gemini website instead of the mobile app.
Posted Sep 12, 2025 - 00:24 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.