Deployment for web-server-trading

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 06:09 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 05:42 EDT

Investigating

Investigating — We identified an issue affecting order placement and cancellation. During this window, attempts to submit or cancel orders would have received an error response. No orders were partially executed or left in an indeterminate state — all affected requests failed cleanly with no partial side effects.

We are actively working to restore full functionality and will provide an update shortly.

Customer impact:

Customers were unable to place new orders.
Customers were unable to cancel existing orders.
Posted Jun 10, 2026 - 05:04 EDT
This incident affected: Gemini ActiveTrader™ and Gemini.com website.