Service Disruption - Password Reset Error
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 06, 2023 - 13:38 EST
Investigating
We are currently investigating reports of password reset issues on the Gemini Mobile App and Web UI. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Jan 06, 2023 - 03:34 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.