Service Disruption - Debit Card Purchases
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 16:05 EST
Monitoring
We have identified an issue with an upstream vendor causing intermittent debit card issues, but those issues have subsided for now. We will continue to monitor until we can confirm no further impact. All customer accounts and funds remain completely secure.
Posted Nov 18, 2020 - 13:10 EST
Investigating
Gemini is investigating reports of potential service disruptions involving debit card purchases. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Nov 18, 2020 - 12:54 EST