BTC deposit processing delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 04, 2021 - 16:54 EST
Identified
We are currently investigating an issue impacting the processing times of BTC deposits. All customer funds remain secure.
Posted Mar 04, 2021 - 15:02 EST
This incident affected: Digital Currencies (Bitcoin Deposits and Withdrawals).