Sky Pricing

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 20:18 EDT

Monitoring

We are aware of a display discrepancy where SKY token is reflecting a price of $1.00 rather than the accurate market price of approximately $0.07. This results in inflated portfolio balance displays. Trading functionality remains disabled for migration, and we are working to correct the display.
Posted Sep 11, 2025 - 10:24 EDT