API endpoint /v1/mytrades not returning all trades

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 20, 2026 - 21:49 EDT

Investigating

We have identified an issue with /v1/mytrades endpoint missing some trades for selected accounts.
All trading systems remain available, and this is affecting trade history only.
Posted May 19, 2026 - 22:00 EDT
This incident affected: REST API.