Credit Card Dashboard Degraded Performance 10/7/24
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 16:42 EDT
Investigating
Users are not able to see their dashboard to view transactions or make payments. All customer accounts and funds remain secure. Further updates to follow.
Posted Oct 07, 2024 - 11:41 EDT
This incident affected: Gemini Credit Card™.