Staking Withdrawals and Rewards Degraded Performance 12/03/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 20, 2024 - 19:34 EST
Update
All customer accounts and funds remain completely secure. Updates will be provided once they are available. Staking rewards are being reviewed and may be corrected with subsequent credits for some accounts. We remain committed to ensuring account accuracy and appreciate your continued trust.
Posted Dec 11, 2024 - 19:43 EST
Investigating
All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Dec 03, 2024 - 11:23 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.