Gemini Credit Card missing or incorrect payment due date

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 09:50 EDT

Investigating

We are currently investigating missing or incorrect payment due dates from GeminI Credit Card statements and in-app messaging.
Posted Aug 25, 2025 - 15:58 EDT
This incident affected: Gemini Credit Card™.