ACH deposits failing

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 27, 2026 - 14:27 EDT

Investigating

If the ACH deposits are not dual approved within 24 hours, they will be failed. This applies to deposit, instant buy, recurring buy involving ACH.
Posted Sep 27, 2026 - 04:26 EDT
This incident affected: Recurring Orders and Fiat Deposits and Withdrawals.