Digital asset deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
All digital asset deposits and withdrawals are now available.
Posted Mar 31, 2020 - 16:00 EDT
Investigating
All digital asset deposits and withdrawals are temporarily unavailable while we perform a required update. All customers' assets remain secure. We will provide further updates as necessary.
Posted Mar 31, 2020 - 15:49 EDT
This incident affected: Digital Currencies (Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, Litecoin Deposits & Withdrawals, Zcash Deposits & Withdrawals, Bitcoin Cash Deposits & Withdrawals, Gemini Dollar Withdrawals & Redemptions).