Duplicate Email or Push Notification regarding Credit Limit or New Card

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 14:57 EDT

Investigating

Some customers may have received, or may still receive, extra notifications. The Gemini Credit Card’s functionality is not affected. We are working on a fix and will provide an update as soon as more information becomes available.
Posted Oct 22, 2025 - 00:33 EDT
This incident affected: Gemini Credit Card™.