Service Disruption - Mobile app unavailable on Google Play Store (UK)

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Oct 23, 2024 - 06:57 EDT

Monitoring

The Gemini mobile app is currently unavailable for downloads and updates via Google Play Store in the UK. We are actively working on a resolution.

In the meantime, UK users may continue to use Gemini via web browser.

All customer accounts and funds remain completely secure. Further updates to follow.
Posted Oct 07, 2024 - 09:43 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.