Service Disruption Impacting Web and Mobile User Interfaces
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 08:46 EST
Monitoring
Service has been restored and Gemini is actively monitoring.
Posted Nov 24, 2020 - 08:08 EST
Investigating
Gemini is investigating reports of potential service disruptions impacting Web and Mobile UIs. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Nov 24, 2020 - 07:44 EST
This incident affected: Gemini ActiveTrader™, Gemini Web UI, and Gemini Mobile App.