Delayed order completion email notifications

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 05:34 EDT

Investigating

We are experiencing a delay in processing order records, which may cause some users to see delayed or missing order completion email notifications. No records are missing. However some customers may not be able to receive emails for fully filled orders, or receive them with a delay.
Posted Sep 04, 2026 - 01:52 EDT