TON Deposits and Withdrawals Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 16:31 EDT

Investigating

TON deposits and withdrawals are delayed. All customer accounts and funds remain completely secure.
Posted Jul 09, 2026 - 13:08 EDT
This incident affected: Crypto Deposits and Withdrawals.