Crypto token prices are not being displayed
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 07:38 EDT
Investigating
We have identified an issue where the crypto token prices are currently not being displayed. All customer accounts and funds remain secure. We will provide further updates as they become available.
Posted Mar 15, 2024 - 02:42 EDT
This incident affected: Gemini Web UI: Uptime SLA 99.95%.