Deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 20:36 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2020 - 20:31 EDT
Identified
Deposits and withdrawals are temporarily unavailable. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Mar 26, 2020 - 20:31 EDT
This incident affected: Digital Currencies (Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, Litecoin Deposits & Withdrawals, Zcash Deposits & Withdrawals, Bitcoin Cash Deposits & Withdrawals, Gemini Dollar Withdrawals & Redemptions).