Incorrect Price Alerts being sent - 11/13/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 20:49 EST
Investigating
We are currently investigating where incorrect price alerts are being sent out. All customer accounts and funds remain secure. Further updates to follow.
Posted Nov 13, 2024 - 17:50 EST
This incident affected: Exchange Trading Engine.