SOL Deposits & Withdrawals Temporarily Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 23, 2022 - 15:50 EDT
Investigating
SOL and SPL deposits & withdrawals are temporarily unavailable. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Jul 23, 2022 - 13:38 EDT
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).