Service Disruption - Instant Buy Order for BTCUSD is Temporarily Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 24 days ago. Mar 17, 2025 - 05:13 EDT

Investigating

Instant Buy Order for BTCUSD is temporarily unavailable while we investigate an issue. All customer accounts and funds remain secure. All customer accounts and funds remain secure. Further updates to follow.
Posted 24 days ago. Mar 17, 2025 - 04:39 EDT
This incident affected: Exchange Trading Engine.