Polkadot Deposits are not being displayed for some users.

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 11:43 EST

Update

Some users are not seeing their Polkadot deposits displayed in their account. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Jan 28, 2026 - 17:26 EST

Investigating

We are currently investigating this issue.
Posted Jan 28, 2026 - 17:25 EST
This incident affected: Digital Currencies (Polkadot Deposits and Withdrawals).