Service Disruption - BAL Trading Pairs Paused
Incident Report for Gemini Exchange
Resolved
Trading has resumed on all BAL Trading Pairs.
Posted Nov 12, 2021 - 18:40 EST
Identified
Gemini has temporarily paused BAL Trading Pairs for further maintenance. BALUSD limit orders can be cancelled at this time, but new orders will not be accepted until work is complete.
Posted Nov 12, 2021 - 13:43 EST