Filecoin Deposits and Withdrawals are temporarily disabled.

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 18:04 EST

Investigating

We are currently investigating an issue impacting Filecoin deposits and withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted Nov 05, 2025 - 15:16 EST
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).