Some customers may experience issues placing orders on Web and Mobile.

Incident Report for Gemini Exchange

Monitoring

A fix has been implemented and we are monitoring the results. All funds remain secure.
Posted Jun 03, 2026 - 12:09 EDT

Investigating

Some customers may be unable to place orders on Web and Mobile. We are actively investigating.
Posted Jun 03, 2026 - 11:43 EDT
This incident affects: Gemini ActiveTrader™, Gemini Mobile App: Uptime SLA 99.95%, and Gemini Web UI: Uptime SLA 99.95%.