Solana withdrawals are currently unavailable.

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 12, 2024 - 23:02 EDT

Investigating

Solana Withdrawals are currently not available. We are working to investigate the issue. All customer funds are safe. We will update this page with more information as it becomes available.
Posted Jun 12, 2024 - 16:22 EDT
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).