Mobile Homepage - Credit Card Linking Issue

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 07, 2025 - 17:10 EDT

Investigating

We are currently investigating an issue regarding Credit Card linking on the Mobile Homepage. All customer accounts and funds remain secure. Further updates to follow.
Posted May 07, 2025 - 16:40 EDT
This incident affected: Gemini Credit Card™.