RLUSD Withdrawals Over Ethereum Temporarily Degraded

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 17:37 EDT

Investigating

We are currently investigating an issue impacting RLUSD withdrawals over the Ethereum network. All customer accounts and funds remain secure. Further updates to follow.
Posted Mar 20, 2026 - 14:33 EDT