Instant Orders Temporarily Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jul 11, 2024 - 12:02 EDT

Investigating

We are aware that some customers may be unable to place instant orders at this time. All customer accounts and funds remain secure. Further updates to follow.
Posted Jul 11, 2024 - 11:43 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.