Service Disruption - Mobile App and Gemini Site Login
Incident Report for Gemini Exchange
Resolved
This incident has been resolved and normal service has been restored.
Posted Mar 06, 2023 - 19:25 EST
Investigating
We are investigating reports of users being unable to log in via Mobile App or Gemini site.
Posted Mar 06, 2023 - 17:55 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini.com website.