Service Disruption - Degraded crypto withdrawals for EU Customers

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 04:42 EDT

Update

We are continuing to investigate. As a workaround in the meantime, please try to request your crypto asset withdrawals via the mobile app.
Posted Sep 08, 2025 - 11:49 EDT

Investigating

Our team is currently investigating an issue that affects crypto asset withdrawals for some EU customers. All customer accounts and funds remain secure. Further updates to follow.
Posted Sep 08, 2025 - 05:50 EDT
This incident affected: Crypto Deposits and Withdrawals.