Service Disruption - Tezos Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 19:22 EDT
Investigating
Gemini is investigating reports of potential service disruptions causing delays for Tezos withdrawals. Tezos deposits are unaffected. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Sep 13, 2021 - 11:05 EDT
This incident affected: Digital Currencies (Tezos Deposits and Withdrawals).