Delays in account balances updating after transactions

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 09:24 EDT

Investigating

Customers may experience delays in seeing updated balances following a successful transaction.

All customers' assets remain secure.
Posted Aug 04, 2026 - 08:46 EDT
This incident affected: Exchange Trading Engine.