Service disruption: Credit Card account access & payments
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 22:08 EDT
Investigating
Credit card holders might have intermittent issues with accessing their account/card details as well as scheduling payments. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Mar 11, 2024 - 15:03 EDT
This incident affected: Gemini Credit Card™.