Gemini emails not sent out

Incident Report for Gemini Exchange

Resolved

As an FYI. Issue is resolved.
Posted Nov 06, 2025 - 06:08 EST

Investigating

Emails from Gemini were not sent out from Nov 6, 3:50am to 5am ET
We have identified & resolved issue now.
Posted Nov 06, 2025 - 06:07 EST