BTC transfers are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 27, 2021 - 16:00 EST
Identified
Bitcoin (BTC) withdrawals are temporarily unavailable due to delayed block production. We are monitoring network conditions.
Posted Jan 27, 2021 - 15:48 EST
This incident affected: Digital Currencies (Bitcoin Deposits & Withdrawals).