Gemini Credit Card applications are temporarily suspended
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 03, 2025 - 17:59 EST
Investigating
We are currently investigating an issue leading Gemini Credit Card applications to be temporarily suspended. All customer accounts and funds remain secure. Further updates to follow.
Posted Jan 03, 2025 - 13:22 EST
This incident affected: Gemini Credit Card™.