ETH & ERC-20 tokens are experiencing delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Oct 16, 2021 - 15:02 EDT
Update
We are continuing to investigate this issue.
Posted Oct 16, 2021 - 14:39 EDT
Investigating
We are currently working to resolve an issue impacting ETH & ERC-20 deposit processing times.
Posted Oct 16, 2021 - 12:10 EDT
This incident affected: Digital Currencies (Ethereum Deposits & Withdrawals).