Customers are unable to view their Gemini Credit Card reward stats.
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 18:06 EST
Investigating
Gemini has identified an incident impacting our customers ability to view their total Gemini Credit Card rewards within their account. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Feb 01, 2024 - 16:45 EST
This incident affected: Gemini Credit Card™.